Komme Subclipse i Aptana å jobbe med den nyeste utgivelsen av Subversion

stemmer
37

Versjonen av Subclipse (1.2.4) for tiden tilgjengelig gjennom Aptana automatiske Plugins leder fungerer ikke med den nyeste versjonen av Subversion.

Jeg ser på Subclipse nettsted men at de har 1.4.2 ut for Eclipse. Så jeg la til en ny ekstern oppdatering nettstedet til min Update manager. Da jeg prøvde å installere det, fortalte meg at jeg trengte Mylyn 3.0.0 . Så etter mye søker jeg fant Mylyn 3.0.0 og lagt en ny ekstern oppdatering nettstedet til min oppdatering manager. Så når jeg prøvde å installere det, det fortalte meg at jeg trengte org.eclipse.ui 3.3.0 eller tilsvarende.

Ser vi på konfigurasjonsdetaljer for Aptana, ser det ut som det er bygget mot eclipse 3.2.2.

Vet noen om det er en måte å oppgradere den versjonen av Eclipse Aptana som er bygget mot til 3.3.0? Eller hvis det er noen annen måte å få Subclipse å jobbe med de aller nyeste versjonen av Subversion?

Jeg vet dette er ikke nødvendigvis en programmering spørsmål, men jeg håper det er ok siden det er svært relevant for erfaring med programmering.

Publisert på 01/08/2008 klokken 13:56
kilden bruker
På andre språk...                            


4 svar

stemmer
16

Subclipse krever ikke Mylyn, men oppdateringen nettstedet inneholder en plugin som integrerer Mylyn og Subclipse. Dette er ment for personer som bruker Mylyn. I ditt tilfelle, vil du ønsker å bare velge bort Mylyn i dialog oppdateringen.

Subclipse krever også Subversion 1.5 og den tilsvarende versjon av JavaHL innfødte biblioteker. Jeg har skrevet starten på en FAQ for å hjelpe folk å forstå JavaHL og hvordan du kan få det. Se: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Svarte 15/09/2008 kl. 13:26
kilden bruker

stemmer
7

Jeg har hatt problemer med JavaHL i Eclipse Ganymedes, da det fungerte fint i Eclipse Europa. Jeg er ikke sikker på hvordan Aptana er forskjellig, men prøv heller å oppgradere JavaHL eller bytte til den rene-java SVNKit implementering innenfor Subclipse config.

Svarte 01/08/2008 kl. 14:41
kilden bruker

stemmer
4

hvis du ikke skal bruke mylyn bare fjerne merket at avhengighet. Jeg er ikke veldig kjent med Aptana, men i eclipse du kan utvide hva som blir installert, og fjern merket noe du ikke trenger.

Svarte 28/08/2008 kl. 23:47
kilden bruker

stemmer
3

Jeg brukte oppdateringen url og jeg installerte JavaHL adapter, den Subclipse prosjektet selv og den SVNKit adapter BETA.

Etter dette er det fungerte fint for meg, dette er for linux plattform håper det fungerer for deg.

Svarte 26/08/2008 kl. 13:41
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more